[CWB] rcqp installation / compilation

Andreas Blätte andreas.blaette at uni-due.de
Sun Apr 23 21:23:12 CEST 2017

Dear colleagues,

if I recall it correctly, the problem occurs with rcqp version 0.5 that 
you get via svn. The version 0.4 available at CRAN 
(https://cran.r-project.org/package=rcqp) is stable.

For the R package polmineR I am working on, I've experimented with Rcpp 
wrappers to expose CWB/CL functionality in R (see 
https://github.com/PolMine/polmineR.Rcpp). It works fine for my 
purposes, but it is not yet documented properly and does not do all the 
safety checks that make the rcqp stable and reliable.

Kind regards


Am 23.04.17 um 18:26 schrieb Ruprecht von Waldenfels:
> Dear Stefan,
> thank you for your as always quick and helpful response! I did not get 
> back to you back then, and I think this is because I didn't solve the 
> problem.
> I solved it now, but only because I found some old version of rcqp on 
> my machine and then proceeded as you suggested.
> Before, I used
> svn checkout svn://scm.r-forge.r-project.org/svnroot/rcwb/pkg/rcqp
> to get a version of rcqp. Here, the problem persisted even though the 
> ".yy." and ".tab."  files  you mentioned were not there to begin with.
> Thank you again and best wishes!
> Ruprecht
> Am 23.04.2017 um 17:26 schrieb Stefan Evert:
>>> On 23 Apr 2017, at 16:20, Ruprecht von Waldenfels 
>>> <ruprecht.waldenfels at gmx.net> wrote:
>>> I am (once again) trying to install rcqp on a linux machine, and an 
>>> old problem surfaces (below) that I seem to have been able to solve 
>>> last time, but I cannot figure out, how. This is on a 14.04 64 bit 
>>> server.
>>> It's the same error I got 18 months ago. However, the solution was 
>>> to delete certain files from the distribution that I cannot find now.
>>> What could be the problem?
>> Last time I wrote
>>> I suspect this is a mismatch between the flex / bison libs on your 
>>> machine and the (auto-generated) bison parser included in the source 
>>> distribution of the rcqp package.
>>> If you unpack the .tar.gz, remove the files named
>>>     *.tab.*
>>>     *.yy.*
>>> from subdirectories
>>>     rcqp/src/cwb/cl
>>>     rcqp/src/cwb/cqp
>>> and repack the tree under the same .tar.gz filename, the bison 
>>> parser will be re-compiled when the package is installed and 
>>> hopefully everything will be fine.
>> and since I don't think I heard back from you then, this may have 
>> solved your problems.
>> Best,
>> Stefan
> _______________________________________________
> CWB mailing list
> CWB at sslmit.unibo.it
> http://liste.sslmit.unibo.it/mailman/listinfo/cwb

More information about the CWB mailing list